Topic: Safari & Firefox – Load More | WP Masonry Layout

Safari & Firefox – Load More

Home Forums Lite Version Safari & Firefox – Load More

This topic contains 11 replies, has 2 voices, and was last updated by  Masonry Guy 1 month, 2 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #15493 Reply

    Kevin77

    I’m having an issue with with plugin not automatically loading the posts. It sits with the Load More button without displaying the first posts.This happens only in Safari and Firefox (maybe IE). In Chrome there are no issues.

    I’m not seeing any console errors.

    Any help you could provide would be great.

    Blog

    #15498 Reply

    Masonry Guy
    Keymaster

    Hi Kevin77,

    It is not working at all here to me. Even in Chrome. Also i couldn’t find any js error. So i am yet unknown why this is not working in first load. So to test this, can you please change your theme with wordpress default theme ? May be there some conflict in theme and it is blocking it. Also, please try deactivating other plugins and see if this works.

    Once you find out what is causing it, please kindly let me know i will investigate it further.

    Thanks

    #15500 Reply

    Kevin77

    It appears to be an issue with caching.

    Does WP Masonry work with any caching plugins?

    #15501 Reply

    Masonry Guy
    Keymaster

    Hi Kevin,

    Our plugin should work fine with cache plugin. Which cache plugin you are using ? May be can you try flushing the cache of the plugin and see if this works. Also, can you please confirm your cache plugin allows ajax call.

    Thanks

    #17792 Reply

    Phil01

    Hello, I am encountering the same exact problem: Safari and Chrome do not load any posts.
    For cache, I use W3 Total Cache…

    Thanks

    #17793 Reply

    Masonry Guy
    Keymaster

    Hi Phil01,

    I found that some of the js are not loading in your server due to blocking of mixed content. So our plugin is unable to get the jquery library. Here is the details about the error. http://oi64.tinypic.com/xl9dhi.jpg .

    Here the cause is that, your site is using https (SSL) and those js are being used from non https url. So it is getting blocked. Please force all urls to be ssl and this should fix the issue.

    Thanks

    #17799 Reply

    Phil01

    Thank you for you reply. So tried to do what you suggested by applied the following changes:
    http://www.inmotionhosting.com/support/website/ssl/how-to-force-https-using-the-htaccess-file

    Yet now even in Firefox the posts do not load and the page stays stuck on “Load More”.

    Thanks

    #17801 Reply

    Phil01

    Actually I undid the previous changes and applied the “Really Simple SSL” plugin. Now firefox auto loads the posts, but still no auto loading of the posts in Chrome or internet explorer…

    #17803 Reply

    Masonry Guy
    Keymaster

    Hi Phil01,

    In that case, please send me your wp-admin details using the form here http://www.masonrylayout.com/rectify-my-problem/ .

    I will investigate it from here and try to fix it.

    Thanks

    #18340 Reply

    Nita Yager

    I’m having the save problem if I have the Autoptimize plugin activated. It works fine if I don’t. Is there a work around?

    #18350 Reply

    Masonry Guy
    Keymaster

    Hi Nita,

    Do you mean that deactivating Auto Optimize works ?

    Thanks

    #18351 Reply

    Masonry Guy
    Keymaster

    Hi Nita,

    Do you mean that deactivating Auto Optimize works ?

    Thanks

Viewing 12 posts - 1 through 12 (of 12 total)
Reply To: Safari & Firefox – Load More
Your information: